Back to overview
Resolved
High volume of Google jobs in maintenance
Jul 27, 2026 at 8:32am UTC
Affected services
reviewscraper.datashake.com
Resolved
Jul 28, 2026 at 7:39am UTC
The backlog has largely cleared and processing has been stable since yesterday morning. We will continue monitoring. Thanks for your patience.
Affected services
Created
Jul 27, 2026 at 8:32am UTC
A large volume of Google jobs is currently in maintenance. Processing speed has returned to normal, but it will take some time to clear the backlog. We'll continue monitoring and will update as it progresses. Thanks for your patience.
Affected services