Back to overview
Maintenance

Datashake Hub maintenance window | 19th of May

May 19, 2026 at 12:00pm UTC  –  May 19, 2026 at 2:00pm UTC
Affected services
datashake-hub-api.datashake.com

Resolved
May 19, 2026 at 2:00pm UTC

Maintenance ended

Created
May 19, 2026 at 12:00pm UTC

We will be carrying out maintenance work for the Datashake Hub tomorrow Tuesday the 19th of May between 1pm and 3pm UTC.

This work is not expected to impact job processing. We will be actively monitoring throughout and will notify you if any issues arise.

Thank you for your understanding. If you have any questions, please feel free to reach out.