Back to overview
Degraded
Slow Job Processing
Mar 19, 2026 at 07:13am UTC
Affected services
app.datashake.com
reviewscraper.datashake.com
datashake-hub-api.datashake.com
Resolved
Mar 19, 2026 at 02:59pm UTC
The services are back to normal processing speed and we are currently going through the backlog of requests. Thanks for your patience.
Affected services
Created
Mar 19, 2026 at 07:13am UTC
We are currently experiencing slow job processing, which has caused an increase in the pending jobs queue.
Our team is actively investigating and working to resolve the issue as quickly as possible.
Affected services