Get in touch
Back
Degraded

Google review collection disruption

Started 29 May at 10:08am GMT+0, resolved 31 May at 07:22am GMT+0.

app.datashake.com reviewindexapi.datashake.com webscraperapi.datashake.com datashake-hub-api.datashake.com reviewscraper.datashake.com
Resolved

We have successfully cleared the backlog of requests, and services have returned to normal operations.

Please note that a few sources are still experiencing lower success rates or issues. These issues are unrelated to the recent incident, and our team is working to resolve them.

Thank you for your patience and understanding throughout this process.

Posted 31 May at 07:22am GMT+0.
Updated

All services are now back online, and we are actively working through the backlog of requests. We’re closely monitoring success rates and making adjustments as needed to ensure stable performance.

While all sources are currently processing requests, a few are still experiencing issues that are unrelated to the initial incident. Our team is continuing to investigate and resolve these, alongside monitoring overall system performance.

We’ll provide another update once the backlog has been fully cleared.

Posted 30 May at 02:03pm GMT+0.
Updated

Our team has been working diligently over the past 24 hours to restore full service. While systems are back up and running, we’re still in the process of stabilizing performance.

We are now processing again, but not yet at our usual levels for some sources. Resolving these remaining issues and clearing the backlog of requests are our top priorities today.

We’ll continue to keep you informed as we make further progress.

Posted 30 May at 06:07am GMT+0.
Updated

We are currently experiencing a broader service degradation that is now affecting all review sources. This includes disruptions in data collection and performance across multiple services, including the Location Search API and Hub.

Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible. We understand the impact this may have and will continue to provide updates as we make progress.

Posted 29 May at 02:34pm GMT+0.
Created

We are currently experiencing issues collecting reviews from Google due to recent changes made on their end. This disruption is also impacting functionality related to the Location Search API.

Our team is actively investigating and working toward a resolution. We will keep you updated as we make progress.

Thank you for your patience and understanding.

Posted 29 May at 10:08am GMT+0.