Get in touch
Back
Maintenance

Scheduled maintenance on Sunday 19th of November

Completed 19 Nov at 01:00pm -01.

app.datashake.com
Completed

Maintenance completed

Posted 19 Nov at 01:00pm -01.
Started

Our services will be unavailable for a few hours on Sunday the 19th of November due to a scheduled maintenance.

This maintenance is essential to ensure the continued reliability and performance of our services. We will monitor the performance of the services following the work and will keep you updated if unforeseen issues arise.

Thanks for your patience and understanding.

The Datashake team

Posted 19 Nov at 09:00am -01.