Get in touch
Back
Maintenance

Datashake maintenance

Completed 2 Sep at 02:00pm +00.

app.datashake.com
Completed

Maintenance completed

Posted 2 Sep at 02:00pm +00.
Started

Our services will be unavailable for a few hours on Saturday the 2nd of September due to a scheduled maintenance.

This maintenance is essential to ensure the continued reliability and performance of our services.

We understand the importance of our services to your business, and we apologize for any inconvenience this may cause.

Thanks for your patience and understanding.

The Datashake team

Posted 2 Sep at 11:00am +00.